EMSISOFTHelpdesk
Knowledgebase:
I did not receive the password or confirmation email after creating a new user account
Posted by Fabian Wosar, Last modified by Orlando Pivi - Emsisoft on 11 July 2015 22:39

The registration email is sent automatically by our servers immediately after you create a forum, License Center or helpdesk account. Usually it only takes a few minutes until you can see the email in your inbox. If you didn't receive the email, the most likely reasons are:

  • Spam/Junk Mail Filter Settings
    Check your spam (junk mail) filter or contact your internet service provider if the email was wrongly filtered. The more popular free email providers such as Hotmail, Yahoo, Verizon or GMX use very restrictive spam filters which mark most automatically sent emails as spam.
    Also, please note that if you use a spam filter that requires a manual confirmation by the sender (sometimes called a challenge/response system), it will not work with our helpdesk system.
  • Wrong Email Address
    Please make sure that you carefully type your email address, and review it for typos before submitting. In our experience, after spam filters, simple typos are the most common reason for a missing password or registration mail.
  • Email Routing Problems
    Sometimes, mailservers have technical problems which may result in a long delay or non delivery. Mails may hang in queues for hours or days because of the high traffic. Mailservers may be overloaded because of spam and worm emails. Try to send a test email to yourself to ensure the email address is working correctly.

In addition, if you have lost your password for one of the Emsisoft services, you can read the dedicated article in our helpdesk: I have lost my password for an Emsisoft online service. What should I do?

(67 vote(s))
Helpful
Not helpful